PLZ (3W/3WH/4W/4WA/4WL/4WH/U) Series – IVI-COM Multi-Environment Drivers

未設定メニュー

IVI-COM Multi-Environment Drivers

An IVI-COM multi-environment instrument driver compliant with the IVI specifications. Compatible with Microsoft Office VBA, Visual Basic 6.0, Visual Basic.NET. And because an IVI-C driver is bundled, it is possible to use it easily in LabVIEW and LabWindows/CVI.

Ver.

2.0.3.22

Last update

2016/9/15

Configuration

  • 7(x86/x64)
  • 8(x86/x64)
  • 10(x86/x64)
  • GPIB/RS-232C/USB

Notes

  • To use IVI-COM instrument drivers, a VISA Library that supports VISA COM.
  • We recommend using one of the VISA Libraries supporting VISA COM shown below. (Mind that multiple versions of VISA cannot be installed at a time.)
    • NI-VISA 5.x or later
    • Agilent IO Libraries Suite 15.5 or later
    • KI-VISA 5.x or later
  • When using 32bit OS, the x86 edition of the instrument driver can only be installed.
  • When using 64bit OS, both x64x86 editions of the instrument driver must be installed independently as your need.

Download

Common Library / Documents

VISA Libraries
IVI Instrument Driver Programming Guide

  • 2024-04-22 README
    [KikusuiPlz IVI-COM Instrument Driver] README
    
    Last Update 06/Jul/2016
    --------------------------------------------------
    
    The KikusuiPlz is the IVI-COM instrument driver that complies with the
    IVI specifications. The driver can be used with most of ADEs (application
    development environment) such as Microsoft Developer studio, Microsoft
    Office VBA, National Instruments LabVIEW, etc. as long as the ADE supports
    Microsoft COM (Component Object Model) technologies.
    
    Revision History
    ----------------
    2.0.3.22   06/Jul/2016
    There was an ID-query error when to connect a PLZ-3W model
    
    2.0.2.21   14/May/2013
    There was a crash problem when using in simulation mode
    
    2.0.1.20   18/May/2012
    x64 installer now installs both x64/x86 components, as like as Nimbus installer
    
    2.0.0.18  20/MAY/2010:
    LockObject/UnlockObject behaviour changed. 64bit support added
    
    2.0.0.17  08/MAR/2010:
    New         - Supports PLZ-4WL, Comatible with Windows 7
    New         - IKikusuiPlzInput2, IKikusuiPlzProgram2 interfaces added for additional features
    
    2.0.0.13  15/Feb/2007:
    Bugfix      - Comatible with Windows Vista.
    
    2.0.0.11  20/Jul/2005:
    Bugfix      - State Cache operation had handle leak problem.
    
    2.0.0.10  29/May/2005:
    Improvement - Collaborate with IVI-C driver
    
    1.1.0.7   22/July/2004:
    Bugfix - State cache memory leak fixed.
    
    1.1.0.6   19/Mar/2004:
    Improvement - PLZ-U series is newly supported. 
    Improvement - Reverse Voltage query option is added for QueryState(). 
    Bugfix - Initialize() did not invalidate state cache.
    
    1.0.0.2   10/Oct/2003:
    The first release
    
    
    IVI Compliance Info
    -------------------
    
    IVI Compliance Category:
    IVI-COM Custom Specific Instrument Driver
    
    Optional Features:
    Interchangeability Checking	= False
    State Caching			= True
    Coercion Recording		= False
    
    Driver Specification:
    Driver Revision:		2.0.3.22
    Driver Vendor:			Kikusui
    
    Component Identifier:		KikusuiPlz
    Description:			Electronic Load
    
    Hardware Information:
    Instrument Manufacturer:	Kikusui
    Supported Instrument Models:	All PLZ-4W/4WA/4WL/U models
    Supported Bus Interface:	GPIB, Serial, USB
    
    32-bit Software Information:
    Support Operating Systems:     7(x86), 8.1(x86), 10(x86)
    VISA Library             :     VISA Library of SPEC 5.0
    IVI Shared Components    :     IVI Shared Components 2.0
    IVI Engine               :     NI IVI Compliance Package 4.1 or later (IVI-C only)
    Source Code Availability :     Not available
    
    64-bit Software Information:
    Support Operating Systems:     7(x64), 8.1(x64), 10(x64)
    VISA Library             :     VISA Library of SPEC 5.0
    IVI Shared Components    :     IVI Shared Components 2.0
    IVI Engine               :     NI IVI Compliance Package 4.1 or later (IVI-C only)
    Source Code Availability :     Not available
    
    
    (c)2016 Kikusui Electronics Corp. All rights reserved.
    

如有任何问题或担忧,请与我们联系。

下载产品目录 产品目录
采购考虑/报价要求 Contact Us
close

Search